Audacity Tips and Tricks for Podcasters

Common Challenges in Podcast Recording

Pops and Clicks
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Sometimes audio recordings contain pops or clicks caused by a too-hard “p”, “t”, or “k” sound, by a little
too much saliva as a word is said, or by the microphone recording a sound incorrectly. For a truly
professional podcast, we may want to get rid of any major instances of these pops and clicks.

Solutions

e Find Zero Crossings before deleting the selection.
e Click “Removal”
e Amplification

“Um,” “You Know,” Pauses, and Other Junk

Let’s face it. We don’t always articulate the way we’d like, especially when we’re not using a script. We
may want to edit out words, phrases, filler words such as “um” or “er” or “like”, pauses, or non-constant
background sounds (e.g., the rustling of pages as a script page is turned or the noise of an item dropped
on the floor). However, editing can cause its own problems; for instance, the editing can introduce pops
and clicks.

Solutions

e Find Zero Crossings before deleting selection
e Amplification

Ambient Noise

Recordings intended for podcasts will contain background noise unless they are recorded in a “dead
room” (a soundproof room in a recording studio where the subject of the recording sits, surrounded by
padding that seals him or her off from all outside sound). Even when care is taken to eliminate voices,
music, rustling of papers, and other easily noticed background noise, ambient noise will likely come from
an air conditioner, a computer fan, or other source of constant, low-volume noise. No normal room is
ever truly silent.

Solutions

e Noise Reduction



Differences in Sound from Changes in Location, Equipment, or Subject

Each recording room or other recording location will likely sound a bit different from others because of
differences in how sound reverberates in the space, and any change in recording equipment may cause
sounds to be picked up differently. As a result, podcasts recorded in multiple locations or with multiple
types of recorders may exhibit some inconsistency in ambient sound and in volume. In addition, certain
speakers talk louder than others, and this variable can lead to differences in recording volume when a
podcast contains multiple participants.

Solutions

e Normalization
e Amplification

Multiple Recordings and/or Music Files to Interweave Together

Maybe your podcast is a story, with multiple character voices connected by a narrator, and each actor
recorded his or her part separately from the others. Maybe you are putting together interviews with
multiple guests. Maybe you just want to use stingers or background music files, and you want to control
the fading or volume of these sounds in relation to other voices. You can often imagine complex uses of
audio, and implementing what you imagine can be a challenge.

Solutions

e Time Shift tool

e Fade In/ Fade Out effects
e Envelope tool

e Splitting tracks

e Quick Mix

e Generating silence

Solutions

Zero Crossings

Sounds are made up of waves, and every sound file is represented in the computer as a waveform.
When a portion of a sound is selected with the mouse, the beginning and end of the selection don’t
always (and in fact, usually won’t) line up with a point where this wave crosses the horizontal midline
dividing the crests and troughs. Thus, a selection (very zoomed in) might look like this:




When the selection is deleted, the resulting waveform thus has an irregular drop from the crest on the
left to the trough on the right (or vice versa), like this:
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When the sound is played, this irregular drop is sometimes heard as a pop or click. A pop or click can
also occur when an effect is applied to the selection, when the selection is cut and pasted, when the
selection is replaced by silence, and so on. Fortunately, there is an easy solution. Whenever a piece of a

waveform is selected, choose “Find Zero Crossings” from the Edit menu in Audacity before taking any
action on the selection. This will move the selection both right and left to the nearest point where the
waveform crosses the zero line, like this:

Then, when the selection is deleted (for example), the irregular drop seen above is omitted, as shown
below:
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Click Removal

Audacity also provides a simple, first-pass method to remove clicks and pops from audio files. Select
“Click Removal” from the Effect menu in Audacity. Select the desired threshold and maximum spike
width as described on the dialog box, and the click the “Remove Clicks” button. Keep in mind that the
greater the sensitivity you select, the better the program will remove pops and clicks; however, the
distortion of the desired audio will be greater, as well. The “Preview” button on the Click and Pop
Removal dialog box may help you to find an acceptable level of sensitivity for the particular file you are
working with, but sometimes determining the level is a matter of trial and error, requiring multiple
“Undo” operations. Since each file may require a slightly different setting for optimal results, if your
project contains multiple files, make sure that you do this procedure for only one track or file at a time.

Noise Reduction

Noise reduction works by reducing or eliminating sounds that match frequencies defined in a sample of
what silence (or only constant ambient noise) sounds like in the particular file. Desirable sounds in these
frequencies will also be reduced or eliminated, so if noise reduction is overdone, the audio may sound



tinny, robotic, or otherwise distorted (kind of like talking into a fan). Also, noise reduction is primarily
designed to remove constant sounds, such as the sound coming from an air conditioner or computer
fan; it is far less effective at removing sounds such as rustling papers, background voices, etc.

There are two steps to using noise reduction. First, select a few seconds of the file in which there is
nothing but the ambient noise in the room (computer fans or whatever). Then, choose “Noise Removal”
from the Effect menu in Audacity, and click the “Get Noise Profile” button on the dialog box. Next, select
the files, or section of a file, to which you want to apply noise reduction, and find the zero crossings for
the selection (as described above, in “Zero Crossings”). Finally, choose “Noise Removal” from the Effect
menu in Audacity again, select how much noise reduction to apply with the slider on the dialog box, and
click the “Remove Noise” button. As with Click Removal, the “Preview” button on the dialog box may
help you identify a proper level of noise reduction to use on the particular file, but sometimes
identifying the proper level is a matter of trial and error. Perform noise reduction on only one track or
file at a time.

Normalization

Normalization is a way to apply a consistent volume level across files. It ensures that the waveform of
the normalized file is centered on the zero line, and that the maximum (volume of the file is -3 dB. It is
useful to apply normalization to all of your tracks before beginning to mix your podcast. To normalize
a track, select the entire track and choose “Normalize” from the Effect menu in Audacity. Make sure
both check boxes on the dialog box are checked, and click the “OK” button.

Another tool that is useful in normalization is dynamic range compression (see “Compressor” under the
Effect menu in Audacity). Dynamic range compression reduces the amount of volume difference
between the loudest and quietest points in the selection, preventing the large differences illustrated

below:
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Amplification
The Amplify effect can be used to increase or reduce the volume of the selected track or section of a

track. Amplification can be used to achieve a more consistent volume level, to reduce overly emphasized
sounds (for example, P, T, S) that cause a spike in volume or undesired sounds that can’t be completely



removed. Obviously, its primary purpose is to increase or reduce the volume of any recording, even a
consistent recordings, to desired levels.

To increase or reduce volume, select the desired track or section of track, find the zero crossings for the
selection, and then choose “Amplify” from the Effects menu in Audacity. Type in the decibels by which
you want to increase (positive number) or decrease (negative number) the volume of the selection. This
is the amount by which, not to which, the selection volume will be adjusted. Increments of 3 decibels
work well as a starting point for experimentation. Make sure that the “Allow Clipping” check box is NOT
checked. This prevents the selection from being amplified so high that the top of any piece of the
waveform is chopped off, which would lead to high distortion. Then click the “OK” button.

Amplification amplifies all the sound in the selection, including background noise, and can lead to some
distortion. Also, when reducing volume, bear in mind that amplification cannot undo the distorting
effects of any clipping that happened at the time of recording because of incorrect microphone gain, so
make sure that microphone gain is not set too high. As with all of these effects, use amplification
judiciously. Frequently use the Preview button on the dialog box, plus a healthy dose of trial-and-error,
to find the optimum level of amplification.

Time Shift Tool

The Time Shift tool allows you to drag the contents of a track to any point in time on the project
timeline. This tool is found in the tool palette to the left of the playback controls and looks like this:
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Click on the Time Shift tool, then click and drag the desired track to the proper location on the timeline.

Fade In / Fade Out

You may want to fade in or out certain tracks in your podcast, particularly if you are using stingers or
music to signal the beginning and end of portions of the podcast. To use Fade In / Fade Out, select the
length of the track over which you want the fading to occur. Find the zero crossings. Then, select either
“Fade In” or “Fade Out” from the Effects menu in Audacity, which will result in the volume of the
selection fading to or from complete silence. To fade a track to or from a lower volume, use the
Envelope tool.

Envelope Tool

The Envelope tool is used to increase or decrease the volume of a track gradually (unlike the Amplify
effect) and without going to or from zero volume (unlike Fade In and Fade Out). One example of where
the Envelope tool might be used is to have music playing and then to fade that music to a lower volume
for few seconds as a speaker begins to speak, then keep the volume lower but still audible while the
speaker is speaking, and then gradually bring the volume of the music back to its original level as the
speaker is ending her remarks.

The Envelope tool is found in the tool palette to the left of the playback controls and looks like this:



After clicking the Envelope tool, click the desired track at the point where you want the volume change
to begin. There will be a small handle on the top and bottom edges of the track at this point. Hold the
mouse button down and drag up or down while over one of these handles to increase or reduce the
volume of the track (indicated by the amplitude, or height, of the waveform). Adding multiple such
points on the track allows for complex shaping of the volume. For example fading from full volume to a
lower volume then back to full volume again requires four such points or handles. Illustrated below are
two of those handles, used to lower the volume of music as a speaker begins to talk.
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Sometimes you may want to take what is on one track and split it into multiple tracks, to allow the
pieces to be moved independently on the timeline with the Time Shift tool. One example might be a
recording of a story using multiple voices, where each actor recorded his or her parts separately from
the others, and these parts are imported as one track but must be broken up and interwoven with the
parts of other actors. To split a track, select the section of the track that you want to split out and find
the zero crossings. Then choose “Split” from the Edit menu. The selected section of track will be moved
to a new track, and replaced by silence in the original track.

Splitting Tracks

Quick Mix

Quick Mix is the opposite of splitting a track. It allows you to combine the contents of multiple tracks
into one track. For example, the illustration below shows three tracks:
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And following illustration shows the first and third tracks combined with QuickMix:
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Notice that the position of each track on the timeline is maintained in the combined track. If necessary,
silence is generated between the clips on the combined track.

It is possible to combine tracks that overlap each other on the timeline, but once this is done, the
overlapping sections will NOT be able to be separated, as they will become part of a combined
waveform. Do this only with extreme caution.

Quick Mix is a great way to keep the number of tracks you are working with manageable by combining
tracks once the need for them to be separate has passed. To use Quick Mix, select the desired tracks by
clicking on the track information area to the left of each track (indicated by the red arrow in the
illustration above). Hold down the Shift key while selecting the second and subsequent tracks. Then
choose “Quick Mix” from the Project menu.

Generating Silence

One way to move sections of audio on a track further apart is by splitting the track into two, and then
using the Time Shift tool. Another is to generate silence to lengthen the space between the two
sections. To generate silence, put the cursor on the timeline at the point where you want the silence to
appear, then choose “Silence” from the Generate menu in Audacity. Type in the length of the silence
you want to generate, and click the “Generate Silence” button.

Proactively Addressing Challenges
Because most of the above effects, such as amplification and noise reduction, have both limits on what
they can achieve and possible undesirable side effects, it is important to proactively address challenges



you can anticipate. For example, use a pop filter or windscreen between your mouth and the
microphone to reduce the incidence of pops and clicks. Pop filters are inexpensive, but if needed, a pop
filter can even be constructed from a bent hanger and a piece of nylon stockings.

Make sure that gains on microphones, and distances between microphones and the recording subject,
are set properly so as to minimize the need for amplification. As much as possible, eliminate undesirable
background noise, especially noise such as other voices, paper rustling, etc., from the recording
environment. Use a script when possible to avoid undesired pauses and meaningless filler words like
“um,” “er,” and “like.” Completely finish reading from one page of the script before turning the page
and beginning to read again. This makes the rustling of the pages much easier to edit out than if pages

are rustling while you are still talking.
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